Skip to content
MediumVulnerability

CVE-2022-23569: Tensorflow is an Open Source Machine Learning Framework. Multiple operations in TensorFlow can be used to trigger a…

Identifier
CVE-2022-23569
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 1 day before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 1 day before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 1 day before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

Multiple operations in TensorFlow can be triggered to cause a denial of service through CHECK-fails, which are assertion failures. The issue is similar to TFSA-2021-198, and the maintainers patched the reported instances in several GitHub commits while noting that other similar instances may exist.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherrypicked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3.