MediumVulnerability
CVE-2021-37670: TensorFlow out-of-bounds heap read in UpperBound and LowerBound ops
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2021-37670
- Published
- Record updated
- Affected
- tensorflow < 2.3.4, fixed in 2.3.4, released August 10, 2021, 3 days before disclosure
- tensorflow >= 2.4.0, < 2.4.3, fixed in 2.4.3, released August 10, 2021, 3 days before disclosure
- tensorflow = 2.5.0, fixed in 2.5.1, released August 10, 2021, 3 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.2%
Summary
CVE-2021-37670 affects TensorFlow versions before the fix. An attacker can read outside the bounds of heap-allocated data by sending specially crafted illegal arguments to `tf.raw_ops.UpperBound`, because the implementation does not validate the rank of the `sorted_input` argument. A similar issue exists in `tf.raw_ops.LowerBound`.
Mitigation
Patched in GitHub commit 42459e4273c2e47a3232cc16c4f4fff3b3a35c38. The fix will be included in TensorFlow 2.6.0, and the commit will also be cherry-picked to TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database