Skip to content
MediumVulnerability

CVE-2022-29200: TensorFlow denial of service through tf.raw_ops.LSTMBlockCell input validation

Identifier
CVE-2022-29200
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

TensorFlow versions before 2.9.0, 2.8.1, 2.7.2 and 2.6.4 do not fully validate the input arguments of tf.raw_ops.LSTMBlockCell. The API call does not check the ranks of its arguments, which causes a CHECK-failure when tensor elements are accessed. An attacker can trigger this failure to mount a denial of service attack.

Mitigation

Fixed in 2.9.0, 2.8.1, 2.7.2 and 2.6.4, which contain a patch for this issue.