Skip to content
HighVulnerabilityLLM-specific

CVE-2025-54868: LibreChat exposed testing endpoint allows reading arbitrary chats

Identifier
CVE-2025-54868
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2025-54868 affects LibreChat versions 0.0.6 through 0.7.7-rc1. An exposed testing endpoint, /api/search/test, reads stored chats directly from the Meilisearch engine without proper access control, letting an attacker read chats belonging to arbitrary users. The weakness is classified as CWE-285 (Improper Authorization).

Mitigation

This issue is fixed in version 0.7.7.