Skip to content
HighVulnerabilityLLM-specific

CVE-2025-30202: vLLM denial of service and data exposure via ZeroMQ on multi-node deployment

Identifier
CVE-2025-30202
Published
Record updated
View JSON
Affected
  • vllm >= 0.5.2, < 0.8.5
Fixed in
0.8.5
  • released April 28, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.6%

Summary

CVE-2025-30202 affects vLLM versions from 0.5.2 up to but not including 0.8.5 in multi-node deployments. The primary host binds an XPUB ZeroMQ socket to all interfaces, so any client with network access can connect unless a firewall blocks the port, and receives the internal vLLM state broadcast to secondary hosts. Connecting repeatedly without reading the published data can slow or block the publisher, causing denial of service.

Mitigation

Fixed in 0.8.5.