Skip to content
MediumVulnerability

CVE-2022-35997: TensorFlow denial of service through tf.sparse.cross with non-scalar separator

Identifier
CVE-2022-35997
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's tf.sparse.cross triggers a CHECK failure when its separator input is not a scalar, which can be used to cause a denial of service. The issue is patched in GitHub commit 83dcb4dbfa094e33db084e97c4d0531a559e0ebf, which is included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2, all of which are affected and still in supported range.

Mitigation

Patched in GitHub commit 83dcb4dbfa094e33db084e97c4d0531a559e0ebf, included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. There are no known workarounds for this issue.