HighVulnerabilityLLM-specific
CVE-2026-46440: Flowise checkBasicAuth validates plaintext creds without rate limiting
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2026-46440
- Published
- Record updated
- Affected
- flowise <= 3.1.1
- Fixed in
- 3.1.2
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.3%
Summary
CVE-2026-46440 affects Flowise, a drag and drop interface for building customized large language model flows, prior to version 3.1.2. The checkBasicAuth endpoint validates credentials in plaintext, without rate limiting, using direct comparison, and is classified as CWE-522 (Insufficiently Protected Credentials). NVD had not yet provided an assessment at the time of publication.
Mitigation
This issue has been patched in version 3.1.2.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- flowisenpmLLM dependency since 2024-03-12
Related items
- Medium'Aokigahara' Stealer Targets 'Developer Keyrings' & AI AssistantsSimilar attack · Dark Reading
- HighGHSA-3w55-933p-8pv5: Strands Agents: Local Privilege Escalation via Symlink Attack in Default Session File StorageSimilar attack · GitHub Advisory Database
- HighGHSA-g5ff-637f-6q2m: LiteLLM: internal_user_viewer arbitrary local file read via `vertex_ai_credentials`Similar attack · GitHub Advisory Database
- MediumGHSA-hhww-mrg2-969h: LiteLLM vulnerable to reflected XSS in /sso/debug/callbackSimilar attack · GitHub Advisory Database
- HighCVE-2026-117573: hagent OS command injection through args in arduino and esp32 MCP toolsSimilar attack · NVD/CVE Database