Skip to content
MediumVulnerability

CVE-2022-21733: Tensorflow StringNGrams denial of service through integer overflow

Identifier
CVE-2022-21733
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 1 day before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 1 day before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 1 day before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.8%

Summary

CVE-2022-21733 affects the `StringNGrams` implementation in TensorFlow, an open source machine learning framework. Missing validation on `pad_witdh` lets a negative value reach `ngram_width`, which is later used to allocate parts of the output, causing an integer overflow and an out of memory condition that enables denial of service.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherrypicked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3.