Skip to content
MediumVulnerability

CVE-2022-36005: TensorFlow denial of service via nonscalar min or max in fake_quant

Identifier
CVE-2022-36005
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's tf.quantization.fake_quant_with_min_max_vars_gradient triggers a CHECK failure when its min or max input is nonscalar, which can be exploited for a denial of service attack. The issue is tracked as CVE-2022-36005 and affects versions still in the supported range.

Mitigation

Patched in GitHub commit f3cf67ac5705f4f04721d15e485e192bb319feed. The fix will be included in TensorFlow 2.10.0, and the commit will be cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. There are no known workarounds.