Skip to content
MediumVulnerability

CVE-2022-41909: TensorFlow segfault in CompositeTensorVariantToComponents via invalid input

Identifier
CVE-2022-41909
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `tf.raw_ops.CompositeTensorVariantToComponents` segfaults when the `encoded` input is not a valid `CompositeTensorVariant` tensor. The flaw is tracked as CVE-2022-41909 and affects the TensorFlow releases still within their supported range.

Mitigation

Patched in GitHub commits bf594d08d377dc6a3354d9fdb494b32d45f91971 and 660ce5a89eb6766834bdc303d2ab3902aef99d3d. The fix will be included in TensorFlow 2.11, and the commit will be cherry-picked to TensorFlow 2.10.1, 2.9.3, and 2.8.4.