Skip to content
HighVulnerabilityLLM-specific

CVE-2026-46444: Flowise OpenAI Assistants Vector Store endpoints lack authentication

Identifier
CVE-2026-46444
Published
Record updated
View JSON
Affected
  • flowise <= 3.1.1
Fixed in
3.1.2
  • released April 14, 2026, 55 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

Flowise, a drag-and-drop interface for building customized large language model flows, has an issue in versions prior to 3.1.2 (CVE-2026-46444). The CRUD endpoints for OpenAI Assistants Vector Store, at /api/v1/openai-assistants-vector-store, lack authentication middleware and are not in WHITELIST_URLS. Although the route requires API key auth when accessed that way, no permission checks exist on any operation.

Mitigation

Fixed in 3.1.2.