Skip to content
MediumVulnerability

CVE-2022-35982: TensorFlow denial of service via invalid sparse tensor in SparseBincount

Identifier
CVE-2022-35982
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `SparseBincount` segfaults when given `indices`, `values`, and `dense_shape` inputs that do not form a valid sparse tensor. An attacker can use this crash to trigger a denial of service attack.

Mitigation

Patched in GitHub commit 40adbe4dd15b582b0210dfbf40c243a62f5119fa. The fix will be included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2.