Skip to content
MediumVulnerability

CVE-2022-29205: TensorFlow segfault through tf.compat.v1 ops lacking quantized type support

Identifier
CVE-2022-29205
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

TensorFlow versions before 2.9.0, 2.8.1, 2.7.2, and 2.6.4 are affected by CVE-2022-29205. Calling `tf.compat.v1.*` ops that lack quantized type support passes a `nullptr` to `ParseDimensionValue` for the `py_value` argument, and that pointer is then dereferenced. The result is a segfault and denial of service.

Mitigation

Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.