Skip to content
MediumVulnerability

CVE-2022-29203: TensorFlow denial of service via integer overflow in SpaceToBatchND

Identifier
CVE-2022-29203
Published
Record updated
View JSON
Affected
  • tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2022-29203 affects TensorFlow versions before 2.9.0, 2.8.1, 2.7.2, and 2.6.4. The implementation of `tf.raw_ops.SpaceToBatchND`, across backends including XLA and handwritten kernels, contains an integer overflow whose result is used to allocate the output tensor. The overflow leads to a denial of service through a `CHECK`-failure (assertion failure), as in TFSA-2021-198.

Mitigation

Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.