MediumVulnerability
CVE-2021-37653: TensorFlow crash via floating point exception in ResourceGather op
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2021-37653
- Published
- Record updated
- Affected
- tensorflow < 2.3.4, fixed in 2.3.4, released August 10, 2021, 2 days before disclosure
- tensorflow >= 2.4.0, < 2.4.3, fixed in 2.4.3, released August 10, 2021, 2 days before disclosure
- tensorflow = 2.5.0, fixed in 2.5.1, released August 10, 2021, 2 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.2%
Summary
CVE-2021-37653 affects TensorFlow versions before the fix. An attacker can crash a process by triggering a floating point exception in `tf.raw_ops.ResourceGather`, which divides by `batch_size` without checking that it is not 0.
Mitigation
Fixed in GitHub commit ac117ee8a8ea57b73d34665cdf00ef3303bc0b11, included in TensorFlow 2.6.0. The commit is also cherry-picked to TensorFlow 2.5.1, 2.4.3 and 2.3.4.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database