Skip to content
MediumVulnerability

CVE-2021-41197: TensorFlow is an open source platform for machine learning. In affected versions TensorFlow allows tensor to have a…

Identifier
CVE-2021-41197
Published
Record updated
View JSON
Affected
  • tensorflow >= 2.6.0, < 2.6.1, fixed in 2.6.1, released November 1, 2021, 5 days before disclosure
  • tensorflow >= 2.5.0, < 2.5.2, fixed in 2.5.2, released November 1, 2021, 5 days before disclosure
  • tensorflow < 2.4.4, fixed in 2.4.4, released November 1, 2021, 5 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

TensorFlow allows a tensor to have many dimensions, each of arbitrary size, but the total element count must fit in an `int64_t`. When that count overflows, `MultiplyWithoutOverflow` returns a negative value, which in most of the codebase triggers a `CHECK`-failure that crashes the binary. The flaw resembles CVE-2021-29584.

Mitigation

Fixed in TensorFlow 2.7.0. The fix will also be cherry-picked to TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4.