Skip to content
MediumVulnerability

CVE-2021-37674: TensorFlow denial of service through segmentation fault in MaxPoolGrad

Identifier
CVE-2021-37674
Published
Record updated
View JSON
Affected
  • tensorflow < 2.3.4, fixed in 2.3.4, released August 10, 2021, 3 days before disclosure
  • tensorflow >= 2.4.0, < 2.4.3, fixed in 2.4.3, released August 10, 2021, 3 days before disclosure
  • tensorflow = 2.5.0, fixed in 2.5.1, released August 10, 2021, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-37674 affects TensorFlow versions that lack validation in `tf.raw_ops.MaxPoolGrad`. The `maxpooling_op.cc` implementation does not check the `orig_input` and `orig_output` tensors, so an attacker can trigger a segmentation fault and a denial of service. The source notes that the earlier fixes for CVE-2021-29579 were incomplete.

Mitigation

Patched in GitHub commit 136b51f10903e044308cf77117c0ed9871350475. The fix will be included in TensorFlow 2.6.0, and the commit will also be cherry-picked to TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4.