HighVulnerability
CVE-2022-29208: TensorFlow denial of service and out-of-bounds write in tf.raw_ops.EditDistance
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2022-29208
- Published
- Record updated
- Affected
- tensorflow < 2.6.4, fixed in 2.6.4, released May 16, 2022, 5 days before disclosure
- tensorflow >= 2.7.0, < 2.7.2, fixed in 2.7.2, released May 16, 2022, 5 days before disclosure
- tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 5 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.4%
Summary
TensorFlow versions before 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain incomplete validation in `tf.raw_ops.EditDistance`. Passing negative values can trigger a segmentation fault, causing denial of service, and can also be used to write before the bounds of an array by crafting negative values for `loc`.
Mitigation
Fixed in 2.9.0, 2.8.1, 2.7.2, and 2.6.4.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database