Skip to content
LowVulnerability

CVE-2021-29556: TensorFlow denial of service via FPE runtime error in tf.raw_ops.Reverse

Identifier
CVE-2021-29556
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-29556 affects TensorFlow, an open source machine learning platform. An attacker can trigger a denial of service through an FPE runtime error in `tf.raw_ops.Reverse`, because the implementation divides by the first dimension of the tensor argument.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, 2.3.3, 2.2.3 and 2.1.4, which are affected and still in supported range.