Skip to content
MediumVulnerability

CVE-2022-35969: TensorFlow denial of service via Conv2DBackpropInput input_sizes

Identifier
CVE-2022-35969
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's implementation of `Conv2DBackpropInput` requires `input_sizes` to be 4-dimensional. When it is not, the operation fails a `CHECK`, which an attacker can trigger to cause a denial of service. The issue is tracked as CVE-2022-35969.

Mitigation

Patched in GitHub commit 50156d547b9a1da0144d7babe665cf690305b33c. The fix will be included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. There are no known workarounds.