Skip to content
MediumVulnerability

CVE-2022-35967: TensorFlow QuantizedAdd segfault via min_input or max_input tensors

Identifier
CVE-2022-35967
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `QuantizedAdd` crashes with a segfault when given `min_input` or `max_input` tensors of nonzero rank, enabling a denial of service attack. The issue is tracked as CVE-2022-35967 and patched in GitHub commit 49b3824d83af706df0ad07e4e677d88659756d89.

Mitigation

Patched in GitHub commit 49b3824d83af706df0ad07e4e677d88659756d89. The fix will be included in TensorFlow 2.10.0 and cherrypicked to TensorFlow 2.9.1, 2.8.1 and 2.7.2.