Skip to content
MediumVulnerability

CVE-2022-23586: Tensorflow denial of service via altered SavedModel crashing Python interpreter

Identifier
CVE-2022-23586
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 3 days before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 3 days before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.8%

Summary

CVE-2022-23586 affects TensorFlow, an open source machine learning framework. A malicious user can alter a `SavedModel` so that assertions in `function.cc` are falsified, crashing the Python interpreter and causing a denial of service. The record is classified under CWE-617, Reachable Assertion.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, which are also affected and still in supported range.