MediumVulnerability
CVE-2022-35993: TensorFlow is an open source platform for machine learning. When `SetSize` receives an input `set_shape` that is not a…
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2022-35993
- Published
- Record updated
- Affected
- tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.5%
Summary
TensorFlow's `SetSize` function fails a `CHECK` when its input `set_shape` is not a 1D tensor, which can be triggered to cause a denial of service. The issue is patched in GitHub commit cf70b79d2662c0d3c6af74583641e345fc939467 and will ship in TensorFlow 2.10.0. The fix will also be cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2, which are affected and still in supported range.
Mitigation
Fixed in TensorFlow 2.10.0 via GitHub commit cf70b79d2662c0d3c6af74583641e345fc939467, which will also be cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. There are no known workarounds for this issue.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database