Skip to content
HighVulnerabilityLLM-specific

CVE-2025-62164: vLLM memory corruption through prompt embeddings in Completions API

Identifier
CVE-2025-62164
Published
Record updated
View JSON
Affected
  • vllm >= 0.10.2, < 0.11.1
Fixed in
0.11.1
  • released November 18, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.0%

Summary

vLLM versions 0.10.2 up to but not including 0.11.1 contain a memory corruption flaw in the Completions API endpoint. The endpoint calls torch.load() on user-supplied prompt embeddings without sufficient validation, and PyTorch 2.8.0 disables sparse tensor integrity checks by default, so crafted tensors can trigger an out-of-bounds write during to_dense(). The result is a crash (denial-of-service) and potentially code execution on the server hosting vLLM.

Mitigation

This issue has been patched in version 0.11.1.