Skip to content
MediumVulnerability

CVE-2022-35964: TensorFlow denial of service through BlockLSTMGradV2 input validation

Identifier
CVE-2022-35964
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's `BlockLSTMGradV2` implementation does not fully validate its inputs, which causes a segfault that can be used to trigger a denial of service attack. The issue affects TensorFlow versions 2.7.2, 2.8.1 and 2.9.1 as well as earlier releases in their supported range.

Mitigation

Patched in GitHub commit 2a458fc4866505be27c62f81474ecb2b870498fa, included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. No known workarounds.