Skip to content

This vulnerability is being actively exploited in the wild, according to the CISA Known Exploited Vulnerabilities catalog. The catalog records known ransomware use. CISA added it on .

CriticalVulnerability

CVE-2025-3248: Langflow code injection in /api/v1/validate/code endpoint

Identifier
CVE-2025-3248
Published
Record updated
View JSON
Affected
  • langflow < 1.3.0, fixed in 1.3.0, released March 31, 2025, 7 days before disclosure
  • langflow-base < 0.3.0, fixed in 0.3.0, released March 31, 2025, 7 days before disclosure
EPSS
100.0%

Summary

CVE-2025-3248 affects Langflow versions prior to 1.3.0. A remote, unauthenticated attacker can send crafted HTTP requests to the /api/v1/validate/code endpoint to inject code and execute arbitrary code. The flaw is listed in CISA's Known Exploited Vulnerabilities Catalog, with a due date of 05/26/2025.

Mitigation

Fixed in 1.3.0 (release tag https://github.com/langflow-ai/langflow/releases/tag/1.3.0; fix referenced in pull request https://github.com/langflow-ai/langflow/pull/6911).