Skip to content
MediumVulnerabilityLLM-specific

CVE-2025-62426: vLLM denial of service via chat_template_kwargs in chat endpoints

Identifier
CVE-2025-62426
Published
Record updated
View JSON
Affected
  • vllm >= 0.5.5, < 0.11.1
Fixed in
0.11.1
  • released November 18, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2025-62426 affects vLLM, an inference and serving engine for large language models, from version 0.5.5 to before 0.11.1. The /v1/chat/completions and /tokenize endpoints use the chat_template_kwargs request parameter in code before validating it against the chat template. Crafted values of that parameter can block the API server for long periods, delaying all other requests.

Mitigation

This issue has been patched in version 0.11.1.