Skip to content
HighVulnerability

CVE-2025-54424: 1Panel remote code execution via incomplete certificate verification

Identifier
CVE-2025-54424
Published
Record updated
View JSON
Affected
  • github.com/1Panel-dev/1Panel/core >= 1.0.0, < 2.0.6, fixed in 2.0.6
  • github.com/1Panel-dev/1Panel/core < 0.0.0-20250730021757-04b9cbd87a15, fixed in 0.0.0-20250730021757-04b9cbd87a15
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.1%

Summary

1Panel, a web interface and MCP Server for managing websites, files, containers, databases and LLMs on Linux servers, is affected through versions 2.0.5 and below. Its HTTPS communication between the Core and Agent endpoints does not fully verify certificates, which allows unauthorized access to interfaces. Because 1Panel exposes many command execution and high-privilege interfaces, this leads to Remote Code Execution.

Mitigation

Fixed in version 2.0.6.