Skip to content
MediumVulnerability

CVE-2022-35985: TensorFlow is an open source platform for machine learning. If `LRNGrad` is given an `output_image` input tensor that…

Identifier
CVE-2022-35985
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

TensorFlow's LRNGrad operation crashes when its output_image input tensor is not 4-D, triggering a CHECK failure. An attacker can use this to cause a denial of service. The issue affects TensorFlow versions still in supported range, including 2.9.1, 2.8.1 and 2.7.2.

Mitigation

Fixed in GitHub commit bd90b3efab4ec958b228cd7cfe9125be1c0cf255, which will be included in TensorFlow 2.10.0. The commit will also be cherrypicked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. There are no known workarounds.