MediumVulnerability
CVE-2022-35983: TensorFlow denial of service through Save and SaveSlices on unsupported dtype
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2022-35983
- Published
- Record updated
- Affected
- tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.5%
Summary
TensorFlow's `Save` and `SaveSlices` operations fail a `CHECK` when run over tensors of an unsupported `dtype`. An attacker can trigger this failure to cause a denial of service.
Mitigation
Fix committed in GitHub commit 5dd7b86b84a864b834c6fa3d7f9f51c87efa99d4, included in TensorFlow 2.10.0. The commit will also be cherrypicked to TensorFlow 2.9.1, 2.8.1 and 2.7.2.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database