Skip to content
LowVulnerability

CVE-2021-29523: TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a denial of service via…

Identifier
CVE-2021-29523
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

TensorFlow contains a denial-of-service flaw in tf.raw_ops.AddManySparseToTensorsMap. Values in sparse_shape are used as output shape dimensions, and the legacy TensorShape constructor hits a CHECK failure when InitDims returns a non-OK status, which an attacker can trigger.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, 2.3.3, 2.2.3 and 2.1.4. Affected code should use BuildTensorShapeBase or AddDimWithStatus instead of the legacy constructor.