Skip to content
LowVulnerability

CVE-2021-29567: TensorFlow denial of service via missing validation in SparseDenseCwiseMul

Identifier
CVE-2021-29567
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-29567 affects TensorFlow's `tf.raw_ops.SparseDenseCwiseMul` operation, which lacks validation. The implementation checks only the rank of its input arguments, not the constraints between their dimensions, so an attacker can trigger internal `CHECK` assertions that terminate the program or write outside the bounds of heap-allocated tensor buffers.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, 2.3.3, 2.2.3 and 2.1.4.