MediumVulnerability
CVE-2022-35991: TensorFlow denial of service via TensorListScatter element_shape rank
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2022-35991
- Published
- Record updated
- Affected
- tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
- tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.5%
Summary
CVE-2022-35991 affects TensorFlow's `TensorListScatter` and `TensorListScatterV2` operations. When either receives an `element_shape` of rank greater than one, it triggers a `CHECK` fail that can cause a denial of service.
Mitigation
Patched in GitHub commit bb03fdf4aae944ab2e4b35c7daa051068a8b7f61. The fix will be included in TensorFlow 2.10.0 and cherry-picked to TensorFlow 2.9.1, 2.8.1 and 2.7.2.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database