Skip to content
MediumVulnerabilityLLM-specific

CVE-2025-62372: vLLM engine crash via malformed multimodal embedding input shape

Identifier
CVE-2025-62372
Published
Record updated
View JSON
Affected
  • vllm >= 0.5.5, < 0.11.1
Fixed in
0.11.1
  • released November 18, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2025-62372 affects vLLM, an inference and serving engine for large language models, from version 0.5.5 before 0.11.1. Passing multimodal embedding inputs with the correct ndim but an incorrect shape, such as a wrong hidden dimension, can crash the vLLM engine serving multimodal models. The flaw is classified as CWE-129, Improper Validation of Array Index, and GitHub rates it CVSS 4.0 8.3 (High), with availability impact only.

Mitigation

This issue has been patched in version 0.11.1.