Skip to content
MediumVulnerability

CVE-2022-23567: Tensorflow integer overflow in Sparse*Cwise* ops enables denial of service

Identifier
CVE-2022-23567
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 1 day before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 1 day before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 1 day before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
1.1%

Summary

TensorFlow's implementations of the `Sparse*Cwise*` ops are vulnerable to integer overflows. An attacker can trigger large allocations, causing out-of-memory denial of service, or cause `CHECK`-fails when building new `TensorShape` objects, causing assert-failure denial of service. The root cause is missing validation of input tensor shapes and direct construction of large `TensorShape` objects from user-provided dimensions.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3.