Skip to content
LowVulnerability

CVE-2021-29555: TensorFlow denial of service through FPE error in tf.raw_ops.FusedBatchNorm

Identifier
CVE-2021-29555
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-29555 affects TensorFlow's `tf.raw_ops.FusedBatchNorm`. An attacker can trigger a denial of service through a FPE runtime error, because the implementation divides based on the last dimension of the `x` tensor, which the user controls.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherrypicked to TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4.