Skip to content
MediumVulnerability

CVE-2025-65107: Langfuse account takeover through crafted URL in SSO provider configurations

Identifier
CVE-2025-65107
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2025-65107 affects Langfuse, an open source LLM engineering platform, in versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0. In SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, an authenticated user who is made to call a specially crafted URL through a CSRF or phishing attack may have their account taken over.

Mitigation

This issue has been patched in versions 2.95.12 and 3.131.0. A workaround is setting AUTH_<PROVIDER>_CHECK.