Skip to content
MediumVulnerability

CVE-2022-41893: TensorFlow denial of service through nonscalar size in TensorListResize

Identifier
CVE-2022-41893
Published
Record updated
View JSON
Affected
  • tensorflow < 2.8.4, fixed in 2.8.4, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.3, fixed in 2.9.3, released November 16, 2022, 3 days before disclosure
  • tensorflow >= 2.10.0, < 2.10.1, fixed in 2.10.1, released November 16, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-41893 affects TensorFlow, an open source machine learning platform. Passing a nonscalar value for the `size` input of `tf.raw_ops.TensorListResize` causes a `CHECK` failure that can be used to trigger a denial of service attack. The affected versions include TensorFlow 2.10.1, 2.9.3 and 2.8.4, which remain in supported range.

Mitigation

Patched in GitHub commit 888e34b49009a4e734c27ab0c43b0b5102682c56. The fix will be included in TensorFlow 2.11, and the commit will also be cherry-picked onto TensorFlow 2.10.1, 2.9.3 and 2.8.4.