Skip to content
LowVulnerability

CVE-2021-29575: TensorFlow denial of service via invalid seq_dim in ReverseSequence

Identifier
CVE-2021-29575
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

TensorFlow's implementation of `tf.raw_ops.ReverseSequence` does not validate the `seq_dim` and `batch_dim` arguments. Negative `seq_dim` values, and similarly invalid `batch_dim` values, can cause a stack overflow or a `CHECK`-failure, depending on the Eigen code version used, leading to denial of service.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2, 2.3.3, 2.2.3 and 2.1.4, which are affected and still in supported range.