Skip to content
LowVulnerability

CVE-2021-29611: TensorFlow denial of service through incomplete validation in SparseReshape

Identifier
CVE-2021-29611
Published
Record updated
View JSON
Affected
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.4.0, < 2.4.2, fixed in 2.4.2, released June 15, 2021, 31 days after disclosure
  • tensorflow-cpu >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 3 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

TensorFlow's `SparseReshape` operation has incomplete input validation. It does not check that its arguments describe a valid sparse tensor, so malformed input triggers a `CHECK` failure that causes a denial of service. The affected versions are TensorFlow 2.4.2 and 2.3.3, along with earlier releases prior to the fix.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2 and TensorFlow 2.3.3.