Skip to content
MediumVulnerability

CVE-2021-29607: TensorFlow SparseAdd incomplete validation allows out of bounds heap write

Identifier
CVE-2021-29607
Published
Record updated
View JSON
Affected
  • tensorflow < 2.1.4, fixed in 2.1.4, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.2.0, < 2.2.3, fixed in 2.2.3, released June 15, 2021, 31 days after disclosure
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 31 days after disclosure
  • and 9 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

CVE-2021-29607 affects TensorFlow's `SparseAdd` implementation in `tensorflow/core/kernels/sparse_sparse_binary_op_shared.cc`. Incomplete validation of the two sparse tensor inputs allows attackers to send invalid tensor triples, leading to null pointer dereference and out-of-bounds heap writes.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherrypicked to TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4.