HighVulnerability
CVE-2022-21730: TensorFlow FractionalAvgPoolGrad out-of-bounds heap read
- Source
- NVD(opens in a new tab)
- Identifier
- CVE-2022-21730
- Published
- Record updated
- Affected
- tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 1 day before disclosure
- tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 1 day before disclosure
- tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 1 day before disclosure
- and 6 more
- Known exploitation
- Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
- EPSS
- 0.8%
Summary
CVE-2022-21730 affects TensorFlow's implementation of `FractionalAvgPoolGrad`. The code does not check whether input tensors are invalid, which lets an attacker read outside the bounds of the heap.
Mitigation
The fix will be included in TensorFlow 2.8.0. The commit will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, which the source identifies as affected and still in supported range.
Affected packages in the Exposure Registry
Matched by package name and ecosystem. Each entry shows whether the package delegates to a language model and how many tracked packages depend on it.
- tensorflowPyPINo LLM dependency detected · 26 tracked dependents
- tensorflow-gpuPyPINo LLM dependency detected · 2 tracked dependents
Related items
- MediumCVE-2026-111372: AI ChatBot for WooCommerce WoowBot plugin authorization bypass in RAG syncSame vendor · NVD/CVE Database
- HighCVE-2026-117560: ATXP Gemini CLI extension OS command injection in runAtxp() via MCP parametersSame vendor · NVD/CVE Database
- CriticalCVE-2026-90970: GitLab AI Gateway prompt template sandbox escape via crafted flow configurationSame vendor · NVD/CVE Database
- MediumCVE-2026-89278: GPTranslate WordPress plugin exposes plaintext API key to unauthenticated usersSame vendor · NVD/CVE Database
- CriticalCVE-2026-19407: Google Cloud Gemini Enterprise Agent Platform SDK for Python bucket squattingSame vendor · NVD/CVE Database