Skip to content
MediumVulnerability

CVE-2022-23571: Tensorflow denial of service via invalid tensor decoding from protobuf

Identifier
CVE-2022-23571
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 3 days before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 3 days before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-23571 affects TensorFlow. When decoding a tensor from protobuf, a `CHECK` assertion can be invalidated by user-controlled arguments when the tensor has an invalid `dtype` and 0 elements, or an invalid shape. An attacker can use this to cause a denial of service in TensorFlow processes.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherry-picked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, which are affected and still in supported range.