Skip to content
MediumVulnerability

CVE-2025-64504: Langfuse project membership APIs expose member names and emails across orgs

Identifier
CVE-2025-64504
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.3%

Summary

CVE-2025-64504 affects Langfuse, an open source LLM engineering platform, from version 2.70.0 up to (but not including) 2.95.11 and 3.124.1. In certain project membership APIs, the server trusted a user-controlled orgId in authorization checks, letting any authenticated user on the same instance list names and email addresses of members and invitees of another organization if they knew its ID. No traces, prompts or evaluations were exposed. The maintainers found no evidence of exploitation on Langfuse Cloud over the last 30 days.

Mitigation

Upgrade to v2.95.11 for major version 2 or v3.124.1 for major version 3. There are no known workarounds.