Skip to content
LowVulnerability

CVE-2021-29554: TensorFlow denial of service through DenseCountSparseOutput runtime error

Identifier
CVE-2021-29554
Published
Record updated
View JSON
Affected
  • tensorflow >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 32 days after disclosure
  • tensorflow >= 2.4.0, < 2.4.2, fixed in 2.4.2, released June 15, 2021, 32 days after disclosure
  • tensorflow-cpu >= 2.3.0, < 2.3.3, fixed in 2.3.3, released June 15, 2021, 32 days after disclosure
  • and 3 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.2%

Summary

TensorFlow, an open source machine learning platform, is affected by CVE-2021-29554. An attacker can trigger a denial of service through a FPE runtime error in `tf.raw_ops.DenseCountSparseOutput`. The implementation computes a divisor from user-supplied `values` data without checking that it is 0 before dividing, so a zero value yields the error.

Mitigation

The fix will be included in TensorFlow 2.5.0. The commit will also be cherry-picked to TensorFlow 2.4.2 and TensorFlow 2.3.3, which are also affected.