Skip to content
MediumVulnerability

CVE-2025-14980: BetterDocs plugin for WordPress sensitive information exposure via scripts()

Identifier
CVE-2025-14980
Published
Record updated
View JSON
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.4%

Summary

CVE-2025-14980 affects the BetterDocs plugin for WordPress in all versions up to and including 4.3.3. The flaw is Sensitive Information Exposure (CWE-200) via the scripts() function. An authenticated attacker with contributor-level access or above can extract sensitive data, including the OpenAI API key stored in the plugin settings.

Mitigation

Fixed in 4.3.4, per the referenced plugin changeset tagged 4.3.4.