Skip to content
MediumVulnerability

CVE-2022-23575: Tensorflow integer overflow in OpLevelCostEstimator::CalculateTensorSize

Identifier
CVE-2022-23575
Published
Record updated
View JSON
Affected
  • tensorflow < 2.5.3, fixed in 2.5.3, released February 2, 2022, 3 days before disclosure
  • tensorflow >= 2.6.0, < 2.6.3, fixed in 2.6.3, released February 2, 2022, 3 days before disclosure
  • tensorflow = 2.7.0, fixed in 2.7.1, released February 2, 2022, 3 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.8%

Summary

CVE-2022-23575 is an integer overflow in TensorFlow's `OpLevelCostEstimator::CalculateTensorSize`. An attacker who can create an operation involving a tensor with a large enough number of elements can trigger it. The flaw is classified as CWE-190 and was reported by GitHub, Inc.

Mitigation

The fix will be included in TensorFlow 2.8.0. The commit will also be cherrypicked to TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, which are also affected and still in supported range.