Skip to content
MediumVulnerability

CVE-2022-35934: TensorFlow denial of service through tf.reshape op overflow

Identifier
CVE-2022-35934
Published
Record updated
View JSON
Affected
  • tensorflow < 2.7.2, fixed in 2.7.2, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.8.0, < 2.8.1, fixed in 2.8.1, released May 16, 2022, 124 days before disclosure
  • tensorflow >= 2.9.0, < 2.9.1, fixed in 2.9.1, released May 23, 2022, 117 days before disclosure
  • and 6 more
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.5%

Summary

CVE-2022-35934 affects the tf.reshape op in TensorFlow. Overflowing the number of elements in a tensor triggers a CHECK-failure (assertion failure), which causes a denial of service. The flaw is patched in GitHub commit 61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555.

Mitigation

Patched in GitHub commit 61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555. The fix will be included in TensorFlow 2.10.0, and the commit will be cherrypicked to TensorFlow 2.9.1, 2.8.1 and 2.7.2. No known workarounds exist.