Skip to content
HighVulnerability

CVE-2024-12029: invoke-ai/invokeai remote code execution through /api/v2/models/install

Identifier
CVE-2024-12029
Published
Record updated
View JSON
Affected
  • InvokeAI >= 5.3.1, < 5.4.3rc2
Fixed in
5.4.3rc2
  • released December 2, 2024, 107 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
6.0%

Summary

CVE-2024-12029 is a remote code execution vulnerability in invoke-ai/invokeai versions 5.3.1 through 5.4.2, reached via the /api/v2/models/install API. The flaw is unsafe deserialization of model files with torch.load without proper validation (CWE-502), so an attacker who embeds malicious code in a model file gets it executed when the file is loaded.

Mitigation

This issue is fixed in version 5.4.3.