Skip to content
MediumVulnerabilityLLM-specific

CVE-2025-48944: vLLM crash through malformed tool input on /v1/chat/completions

Identifier
CVE-2025-48944
Published
Record updated
View JSON
Affected
  • vllm >= 0.8.0, < 0.9.0
Fixed in
0.9.0
  • released May 27, 2025, 2 days before disclosure
Known exploitation
Not listed in the CISA Known Exploited Vulnerabilities catalog at the last check.
EPSS
0.6%

Summary

CVE-2025-48944 affects vLLM versions 0.8.0 up to but excluding 0.9.0. The vLLM backend behind the /v1/chat/completions OpenAPI endpoint does not validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. A single crafted request crashes the inference worker, which stays down until it is restarted.

Mitigation

Fixed in 0.9.0.